Телеграм: @camouf_ru Почта: mihail@bazarow.ru

Ошибка "Invalid highloadblock description" после первой выгрузки из УТ 11.4

Внимание! все сообщения проходят премодерацию. Ваше сообщение появится после проверки
Ответить
RSS
Ошибка "Invalid highloadblock description" после первой выгрузки из УТ 11.4
 
Имеется база 1С УТ 11.4, установили туда модуль. Первый раз сделали выгрузку на новый чистый сайт. В админке на сайте в разделе "1С каталог" - "Основной каталог товаров" при нажатии на последний возникает ошибка:

[Bitrix\Main\SystemException] Invalid highloadblock description ` string(23) =>
"ProductMarkingCodeGroup"
`. (0)
/home/n/nasonovnn/nasonovnn.beget.tech/public_html/bitrix/modules/highloadblock/lib/highloadbl­ock.php:372
#0: Bitrix\Highloadblock\HighloadBlockTable::compileEntity(NULL)
/home/n/nasonovnn/nasonovnn.beget.tech/public_html/bitrix/modules/catalog/lib/product/systemfi­eld.php:755
#1: Bitrix\Catalog\Product\SystemField::getMarkingCodeGroupAction()
/home/n/nasonovnn/nasonovnn.beget.tech/public_html/bitrix/modules/catalog/lib/product/systemfi­eld.php:170
#2: Bitrix\Catalog\Product\SystemField::getGroupActions()
/home/n/nasonovnn/nasonovnn.beget.tech/public_html/bitrix/modules/catalog/lib/grid/panel/produ­ctgroupaction.php:104
#3: Bitrix\Catalog\Grid\Panel\ProductGroupAction->actionProductFieldPanel(array)

#4: call_user_func_array(array, array)
/home/n/nasonovnn/nasonovnn.beget.tech/public_html/bitrix/modules/iblock/lib/grid/panel/groupa­ction.php:111
#5: Bitrix\Iblock\Grid\Panel\GroupAction->get(string, array)
/home/n/nasonovnn/nasonovnn.beget.tech/public_html/bitrix/modules/iblock/lib/grid/panel/groupa­ction.php:85
#6: Bitrix\Iblock\Grid\Panel\GroupAction->getList(array)
/home/n/nasonovnn/nasonovnn.beget.tech/public_html/bitrix/modules/iblock/admin/iblock_list_adm­in.php:4063
#7: require(string)
/home/n/nasonovnn/nasonovnn.beget.tech/public_html/bitrix/admin/iblock_list_admin.php:1

Что может быьть?
 
Скорее всего 1С пытается создать новый HL блок, но он уже существует, с другими настройками.
Попробуйте удалить все HL блоки, и выгрузить еще раз.
Что бы наверняка, вообще удалите модуль HL блоков (вместе с его таблицами) - и установить сново.

PS Не забудте забекапиться перед этим, на всякий случай.
Изменено: Михаил Базаров - 07.03.2020 22:18:05
Ответить
Форма ответов
 
Текст сообщения*
Перетащите файлы
Ничего не найдено
Загрузить картинки
 
Заметки разработчика

Примерно с 2013-го года пишу, короткие и не очень, заметки по разработке сайтов на Битрикс. Возможно, будут полезны кому-то еще. Во всех заметках есть возможность комментирования и обсуждения. Вы можете задавать уточняющие вопросы прямо там- отвечаю или дополняю заметки по возможности.

Заказaть разработку attention